Issues with Alert Sound

maloneyjay1

New member
Hello! Is anyone having issues now or recently with Alerts within custom studies not being performed? I have some conditional Plots which ARE successfully being performed, but attempting to use the same condition as a parameter for an Alert does not seem to currently work. Anyone have a similar instance? Thank you.

EDIT
Little more detail for context; the condition being used successfully is essentially various EMA crossover states. Again it's just odd that the condition is valid and being marked in Plot syntax, but assigning it as an Alert is an issue. I know this is a strange question, I searched for similar issues but had no luck. Thanks again.
 
Last edited:
Hello! Is anyone having issues now or recently with Alerts within custom studies not being performed? I have some conditional Plots which ARE successfully being performed, but attempting to use the same condition as a parameter for an Alert does not seem to currently work. Anyone have a similar instance? Thank you.

EDIT
Little more detail for context; the condition being used successfully is essentially various EMA crossover states. Again it's just odd that the condition is valid and being marked in Plot syntax, but assigning it as an Alert is an issue. I know this is a strange question, I searched for similar issues but had no luck. Thanks again.

@maloneyjay1 Welcome to the usethinkscript forums...

Are you attempting to put the entire conditional code within the alert or are you calculating it first and then using the result as your condition, as you should...???

For future reference, when asking about code problems, always post the code in question using the </> icon, using the Ruby language type for syntax highlighting, so we can see what you are talking about and can perhaps debug it for you...
 

Join useThinkScript to post your question to a community of 21,000+ developers and traders.

@rad14733 Thanks for the reply - will include a snippet in the future for reference. I had several conditional references defined and was attempting to create a 'super' conditional as a parameter, which was the issue.

Appreciate the help and will consider this resolved.
 

Similar threads

Not the exact question you're looking for?

Start a new thread and receive assistance from our community.

87k+ Posts
186 Online
Create Post

Similar threads

Similar threads

The Market Trading Game Changer

Join 2,500+ subscribers inside the useThinkScript VIP Membership Club
  • Exclusive indicators
  • Proven strategies & setups
  • Private Discord community
  • ‘Buy The Dip’ signal alerts
  • Exclusive members-only content
  • Add-ons and resources
  • 1 full year of unlimited support

Frequently Asked Questions

What is useThinkScript?

useThinkScript is the #1 community of stock market investors using indicators and other tools to power their trading strategies. Traders of all skill levels use our forums to learn about scripting and indicators, help each other, and discover new ways to gain an edge in the markets.

How do I get started?

We get it. Our forum can be intimidating, if not overwhelming. With thousands of topics, tens of thousands of posts, our community has created an incredibly deep knowledge base for stock traders. No one can ever exhaust every resource provided on our site.

If you are new, or just looking for guidance, here are some helpful links to get you started.

What are the benefits of VIP Membership?
VIP members get exclusive access to these proven and tested premium indicators: Buy the Dip, Advanced Market Moves 2.0, Take Profit, and Volatility Trading Range. In addition, VIP members get access to over 50 VIP-only custom indicators, add-ons, and strategies, private VIP-only forums, private Discord channel to discuss trades and strategies in real-time, customer support, trade alerts, and much more. Learn all about VIP membership here.
How can I access the premium indicators?
To access the premium indicators, which are plug and play ready, sign up for VIP membership here.
Back
Top