ThinkorSwim Scan Down or Not Working?

Is anyone else having trouble on thinkorswim today running scan queries and custom scans? I've only been able to get 2 scans to return results so far which were both volume related. I've restarted program and computer already. Right now i'm scanning on slowStochastic and the system is telling me no matching results for the code below. like what?

Code:
plot condition = slowk < slowd;
 

BenTen

Administrative
Staff member
Staff
VIP
Just ran my own scanner and it's working.

IYo1AvR.png


Is that your entire scanner? I don't think it's going to work if you just put it into the editor like that.

vvwN1qv.png
 
I'm using thinkscript editor because I was doing custom scans and nothing was working so I tried some very simple scans and I'm still getting nothing.
No its not my entire scan phrasing, I just said that part because that is what I was scanning using the td Ameritrade stochastic slow scan.
jjB0kwa.png
 
I've been trying to get the scan to work since 8:30am its now 11:10am. I've tried all sorts of conditions using < 70, >70, ADX, RSI, VMA, Stochastics, Bollinger bands, Implied volatility. Nothing is working like I said in my question. nothing. It won't find any results. I use these scans daily and have never had this problem before. all my watchlist scans are blank.

I'm not retarded man. of course I'm not just pasting the code into the scanner. doing that wouldn't even let me press ok to get back to the scan to press the scan button.
 

Slippage

Well-known member
TDA may be having problems with the scan servers lately. Someone mentioned in a YouTube video a couple of days ago, as sort of an off-topic aside, that scans they haven't touched in forever have been glitchy recently.
 
Today the custom scans seemed to work fine. Yesterday I wanted to throw my computer out the window. On Reddit a few others were having similar issues with the scan similar to what I experienced yesterday. Didn’t see many issues today so I would guess tos fixed the issues they were having *fingers crossed.

@MerryDay the last time TOS had major issues, I believe it was in September, I had the same issue happen and I had to reinstall the program multiple times before it finally worked for me.
 

Slippage

Well-known member
@mourningwood4521 I'm not sure if this will fix that particular problem... A solution to other TOS problems I had in the past is to delete the usergui folder (C:\Program Files\thinkorswim\usergui). Or you can rename the folder which is what I did the first time I tried it in case it would break my installation. TOS will recreate the folder and download that stuff again when you launch. Quicker than a full uninstall and reinstall.
 
@mourningwood4521 I'm not sure if this will fix that particular problem... A solution to other TOS problems I had in the past is to delete the usergui folder (C:\Program Files\thinkorswim\usergui). Or you can rename the folder which is what I did the first time I tried it in case it would break my installation. TOS will recreate the folder and download that stuff again when you launch. Quicker than a full uninstall and reinstall.
yeah last time I had to delete everything and recreate all my studies and watchlist. I should probably duplicate my workspace and generate a link so I can access it again in case that happens again.
 

Similar threads

Top