Stuck on installing updates?

wtf_dude

wtf_dude

Active member
Anybody else having this problem in the last 24 hours? Won't get past the installing updates screen. I re-upped TOS without doing a complete removal and reinstall (are we absolutely 100% CERTAIN my custom studies won't be wiped??) but it didn't help.
 
BenTen

BenTen

Administrative
Staff
VIP
ThinkorSwim is working fine for me. Are you still having this issue?
 
BenTen

BenTen

Administrative
Staff
VIP
@wtf_dude That's weird, I'm using ToS as we speak. I would remove the software completely and re-install it.
 
R

RickAns

Member
VIP
Maybe you need to upgrade that TRS-80 you have been using to trade on.... :giggle:

Sorry, was in the mood for a chuckle. Seriously though, no delay for an update for me. Hope you get it sorted out soon.
 
rad14733

rad14733

Well-known member
VIP

When TOS hangs at "Installing Updates":

  • Close TOS
  • Use file manager to goto the TOS program directory
  • Delete the corrupt usergui directory
  • Restart TOS and it will recreate a clean usergui directory
No Data Will Be Lost and there is no need to uninstall and reinstall TOS completely...!!!

TOS is usually installed in:

  • "C:\Program Files\thinkorswim" when installed for all users
  • "C:\Users\<username>\AppData\Local\thinkorswim" for a single user

You can find out where by hovering over the desktop icon or by Right-Clicking on the TOS icon, Left-Clicking on Properties, and noting the Start in directory... Alternatively, you can go into file manager and do a search for usergui and delete...

Hope this helps anyone who experiences this issue... I have had to do this a half dozen times...
 
MerryDay

MerryDay

Active member
VIP
@wtf_dude, I push TOS to its limits on a regular basis. I get the program to just completely hang every couple of days w/ scripts that are just way too complicated. After a week or two of having to alt-control-break and re-boot, the program starts to have many many issues, way beyond the usergui file and all I have to uninstall and re-install.

Take it from me, someone who re-installs TOS at least once a month; you will not lose your custom studies, watchlists or scans.
You do lose your workspace which stinks because I have dozens of detached charts and watchlists spread across many monitors.
HOWEVER, I have even found a work-around for the lost workspaces. I save my workspaces as a shared workspace. You don't lose your shared items so reloading them is easy-peezy.

The good news is that after re-installing TOS, it runs so great. Until I then de-grade it with doing what should never be done.
HTH
 
C

codydog

Active member
I kinda remember tos isnt a clean uninstall and leaves 'stuff' behind.

After uninstalling and a restart, i usually run CCleaner (a free app) and it finds the 'stuff' left behind.

Some folks I know run multipe tos' on the same machine, they say it helps, I dunno
 
A

apdusp

New member
backup your custom scripts with export and save workspace, update java, remove completely platform, restart pc, reinstall tos and recover scripts and workspace if necessary
 
wtf_dude

wtf_dude

Active member
I forgot about the usergui file deletion trick. I hadn't had to deal with this in a long time. I used to get people bitching about it when I worked at TD and still forgot lol Fyi, the studies will be saved but your setup will not if you do a reinstall. Just copy all the xml files from the thinkorswim program file folder to another. When you reinstall you just copy them back to the file with the exe and they'll be there just liek before.

Thanks everybody for the responses anyways. It seems updates just take forever nowadays
 
rad14733

rad14733

Well-known member
VIP
I forgot about the usergui file deletion trick. I hadn't had to deal with this in a long time. I used to get people bitching about it when I worked at TD and still forgot lol Fyi, the studies will be saved but your setup will not if you do a reinstall. Just copy all the xml files from the thinkorswim program file folder to another. When you reinstall you just copy them back to the file with the exe and they'll be there just liek before.

Thanks everybody for the responses anyways. It seems updates just take forever nowadays
Unfortunately, this isn't the problem over the past two days... See the other topic on that HERE... I've been doing some research to find where things are going awry...
 
D

David45

Member
2019 Donor
Anybody else having this problem in the last 24 hours? Won't get past the installing updates screen. I re-upped TOS without doing a complete removal and reinstall (are we absolutely 100% CERTAIN my custom studies won't be wiped??) but it didn't help.
Yes, haven't been able to connect at all today and most of yesterday. Just tried again as I type this. No luck. Here's an idea TD Ameritrade, have your IT guys make updates overnight instead of during the trading day!!! This is so unacceptable. Makes me want to go back to using TeleChart which is at least reliable.
 
rad14733

rad14733

Well-known member
VIP
Yes, haven't been able to connect at all today and most of yesterday. Just tried again as I type this. No luck. Here's an idea TD Ameritrade, have your IT guys make updates overnight instead of during the trading day!!! This is so unacceptable. Makes me want to go back to using TeleChart which is at least reliable.
The update, if that is what actually caused the problem, was rolled out last Saturday but systems didn't start having issues until 9:30am yesterday... My system updated either Saturday or Sunday as I got a compatibility error which was my first indication that they had rolled out the update... All worked well until just after Mondays open...
 
H

hockeycoachdoug

Member
2019 Donor
VIP
So that I am crystal clear. If I uninstall TOS and reinstall, I won't lose any of my custom indicators or scans. I will however lose my custom workspaces which I can backup in advance all my XML files (Which appear to be my work spaces) and recopy them back into the directory, Is this correct. I assume you only want to do a basic uninstall via Windows, not a complete uninstall with something like CC Cleaner. A step by step tutorial might be helpful from someone in the know.

*This is a followup to my post- just hung up with TOS support. The guy came right out and said uninstall and reinstall probably won't work as they are having server issues and that they hope to have a patch out tonight to fix. My guess is it's better to just sit tight and be pissed and wait for patch. With that said, I still would like an answer to my above question about what is lost and what is not during the delete/reinstall process for future reference. *
 
Last edited:
wtf_dude

wtf_dude

Active member
@hockeycoachdoug when i did a complete reinstall, the only thing lost is your setup as far as where you have widgets and selectable metrics. You can bypass this my saving your xml files elsewhere and putting back in the program folder after the reinstall. All custom studies etc are saved
 
rad14733

rad14733

Well-known member
VIP
@hockeycoachdoug The tech was correct, you don't need to uninstall and reinstall... I only did so I could examine the log files... And in doing so I lost workspaces but not grids or anything else... Workspaces and Custom Timeframes are about the only things I've noticed missing as of now...

My system was finally back up and running around 2:00 EST and so far is working as expected... I've been reconfiguring things ever since and have been checking out previously unused features...
 
R

RickAns

Member
VIP
Thanks for the xml backup files info. I just made a copy of mine. Just in case.
 
I

inhouselr

New member
I added Welkin's volume projection indictor and my TOS lagged horribly. I deleted it from TOS, deleted the usergui folder, restarted it, but it seems to still be running something in the background. I am running a lot of indicators from this site but it was more or less fine before I tried Welkin's indicator. Anyone has other suggestions?
 
C

codydog

Active member
@inhouselr - you may want to consider running 'task manager' and see what is gobbling up your pc's attention. Sometimes, its not tos(but usually is).
 
rad14733

rad14733

Well-known member
VIP
I added Welkin's volume projection indictor and my TOS lagged horribly. I deleted it from TOS, deleted the usergui folder, restarted it, but it seems to still be running something in the background. I am running a lot of indicators from this site but it was more or less fine before I tried Welkin's indicator. Anyone has other suggestions?
If you aren't stuck at Installing Updates then deleting usergui probably won't help much... I just went through two more days of slow performance Monday and Tuesday, as described HERE... Check to see if anything there sounds familiar...
 
Top