Custom scripts not working in any watchlist columns

B

Break Trader

Member
Hey guys, i been having trouble with watch list columns, any and all custom scripts turn to "custom expression" when i open say AMZN but then I open DPZ and all the custom scripts go back to normal. i have eliminated all the custom scripts from the watch list and tried adding each one separately to see if i can find which one might be the problem, but each one gives me same results, has anyone else had this problem, if so were you able to fix it? or does anyone know the cause? or do i just have to live with it?

Thank you in advance
 
rad14733

rad14733

Well-known member
VIP
You would have to share your watchlist so we can take a look... I've never heard of your current issue... Another option is to contact technical support...
 
MerryDay

MerryDay

Active member
VIP
"custom expression subscription limit exceeded"
You have exceeded your limit of 1500 custom scripts.
 
rad14733

rad14733

Well-known member
VIP
"custom expression subscription limit exceeded"
You have exceeded your limit of 1500 custom scripts.
As Merry Day has stated, too many custom scripts running, or too many complex scripts, usually happens when there are too many entries in your watchlists... It can also happen on a chart that spans too long of a timeframe... These instances can be resolved by reducing the number of custom scripts, reducing the size of your watchlist, or shortening the time span of your chart...
 
B

Break Trader

Member
http://tos.mx/YAFvMK
thank you for your responses. above is a link to the live watch list. im only running 3 scripts and it only turns to "custom expression" on a few charts not all charts.
 
rad14733

rad14733

Well-known member
VIP
http://tos.mx/YAFvMK
thank you for your responses. above is a link to the live watch list. im only running 3 scripts and it only turns to "custom expression" on a few charts not all charts.
Nothing seemingly out of place in the code... How many charts are running this script...???

I've had a few instances recently where charts have become corrupt and needed to be deleted and recreated because they were eating up program resources and slowing TOS to a crawl... Have you checked Help > System to see what your bandwidth throughput looks like...??? If it shows red lines from bottom to top then one of your charts is most likely corrupt... Another thing to try is to delete Thinkorswims usergui directory and let it be recreated when you restart the program...

Edited to add image:

Example of mildly excessive bandwidth throughput...



Example of minimal bandwidth throughput...

 
Last edited:
MerryDay

MerryDay

Active member
VIP
The shared link that you provided is to a study that cannot be used as a watchlist as is... Watchlists can only have one plot
 
rad14733

rad14733

Well-known member
VIP
The shared link that you provided is to a study that cannot be used as a watchlist as is... Watchlists can only have one plot
Ahhh...
@Break Trader Is this a chart or a watchlist problem...
 
B

Break Trader

Member
The shared link that you provided is to a study that cannot be used as a watchlist as is... Watchlists can only have one plot
wow, thats odd, i shared a link to my watch list and im not even running supply and demand on my watch list or any of my charts. I dont even have that script in my studies anymore.
 
B

Break Trader

Member
http://tos.mx/X2VJtBs
lets see if this is the actual watch list
update, i closed all charts and just clicked on the watch list symbols to see how they would react, still about 7 to 10 symbols will changes the "custom expression" while all the rest work fine.
 
Last edited:
rad14733

rad14733

Well-known member
VIP
@Break Trader Your watchlist is working fine for me... No errors but, then again, the markets are closed... However, everything comes into play as far as resources... If you have a lot of complex studies on charts they also contribute to the overall workload...
 
B

Break Trader

Member
@Break Trader Your watchlist is working fine for me... No errors but, then again, the markets are closed... However, everything comes into play as far as resources... If you have a lot of complex studies on charts they also contribute to the overall workload...
Thank you for your report, i closed out all charts and still get the same error on just a few symbols. and it uses a lot of memory when on just those few symbols but seems fine on all the other symbols.
Symbols cause the "custom expression" are AMZN, TSLA, SHOP, NFLX, NVDA, ADBE, Q's, AAPL, SPY, BABA, DIA, ZM and NOW. only 13 of 41 symbols
Not sure why but it seems its mainly tech equities giving me the errors.
 
rad14733

rad14733

Well-known member
VIP
@Break Trader Have you tried rebuilding the watchlist from scratch and deleting the original...???

Also, just for shits and giggles, close TOS and delete the usergui directory... And before you do that, goto Help > System and Click on Collect Garbage...
 
B

Break Trader

Member
@Break Trader Have you tried rebuilding the watchlist from scratch and deleting the original...???

Also, just for shits and giggles, close TOS and delete the usergui directory... And before you do that, goto Help > System and Click on Collect Garbage...
i have already went to used memory page and did the collect garbage and then closed TOS and deleted the userGUI file in think or swim, no change.
as far as rebuilding the watch list, i have cleared my watch list from all custom scripts, problem is i cant figure out how to delete the custom scripts from the custom quotes section of the watch list
 
rad14733

rad14733

Well-known member
VIP
as far as rebuilding the watch list, i have cleared my watch list from all custom scripts, problem is i cant figure out how to delete the custom scripts from the custom quotes section of the watch list
You really should delete that watchlist altogether, not simply clean it up and try to rebuild it... Just as with issues I've had, it's the window itself that is corrupt, not the data or scripts within... I've gone that route and deleting the window in question has been the only fix... Detach and Close... Then restart TOS before rebuilding...

As far as the Custom scripts, delete the content and rename back to Custom##...
 
B

Break Trader

Member
You really should delete that watchlist altogether, not simply clean it up and try to rebuild it... Just as with issues I've had, it's the window itself that is corrupt, not the data or scripts within... I've gone that route and deleting the window in question has been the only fix... Detach and Close... Then restart TOS before rebuilding...

As far as the Custom scripts, delete the content and rename back to Custom##...
Thank you Rad, it took some time but for now i got it working, i reset my work space to default then rebuilt my list and added the custom scripts one by one and so far so good
 
rad14733

rad14733

Well-known member
VIP
Thank you Rad, it took some time but for now i got it working, i reset my work space to default then rebuilt my list and added the custom scripts one by one and so far so good
Ahhh, the missing piece of the puzzle... Forgot to mention that I've also replaced my Workspace in the past to resolve issues... And I forgot to backup my XML files beforehand so I had to reconfigure my preferences... That's a last ditch effort that usually works... You should be good to go...!!! ;) (y)
 
B

Break Trader

Member
Ahhh, the missing piece of the puzzle... Forgot to mention that I've also replaced my Workspace in the past to resolve issues... And I forgot to backup my XML files beforehand so I had to reconfigure my preferences... That's a last ditch effort that usually works... You should be good to go...!!! ;) (y)
luckily I had some chart study's saved so I didn't have to really rebuild my charts, just my watch list then re save the set up
 
X

XeoNoX

Member
if you have custom columns under the options table and have alot of strikes listed it will give you that error as well, you can try lessening the amount of strikes show if you have custom columns listed there.
 
B

Break Trader

Member
luckily I had some chart study's saved so I didn't have to really rebuild my charts, just my watch list then re save the set up
So i added Opening Range Break out back to my charts this morning and it sent my watch list back into being no good again, so im guessing that script is corrupt
 

Similar threads

Top