Supported UNICODE Symbols for chart labels

greco26

Active member
It looks like some basic unicode charecters are supported in Thinkscript but not supported in the chart label. For example, unicode¼ (U+00BC ) shows properly in the AddLabel thinkscript code and it also shows properly on the actual chart label. However, U+2193showes properly in the AddLabel thinkscript code but displays as and unknown character [] on the chart label. How can i get a list of supported Unicode charectors that THinkorSwim supports in labels? Does anyone have any insight into this?
 
Solution
Almost all of them work, you can copy and paste them from right here on this site. Almost all of the characters in the windows character map can also be used also.

nzYq1yL.png
@greco26 I am not aware of any list of usable unicodes but you should be able to use any of the standard Windows emojis accessible via the Windows logo key + ; or Windows logo key + . combinations... On a Mac they can be accessed via the Control + Command + Spacebar key combination...
 

Join useThinkScript to post your question to a community of 21,000+ developers and traders.

@greco26 I am not aware of any list of usable unicodes but you should be able to use any of the standard Windows emojis accessible via the Windows logo key + ; or Windows logo key + . combinations... On a Mac they can be accessed via the Control + Command + Spacebar key combination...
@rad14733 thank you kindly for your response. I’ve been using the option key + the Unicode code to input the emojis into thinkscript but I will try the control + command + space bar and see if that makes a difference in how the chart label displays. Thx!
 
@BenTen hey , I'm sorry to bother you but there was a post on how to show special texts inside the labels of TOS... Do you know about that?
Like not just changing the label color but adding on shapes like squares hearts etc...
Like I already know this but there was a guy on here who knew the codes to put like hearts or other languages and shapes etc inside of the labels???
Driving me crazy I cant find it my friend

https://usethinkscript.com/threads/market-internals-labels-for-thinkorswim.833/
 
Almost all of them work, you can copy and paste them from right here on this site. Almost all of the characters in the windows character map can also be used also.

nzYq1yL.png
 
Solution
Played with Unicode symbols this afternoon...
AddLabel(yes, " 👍 👎 🆗 🆙 🆒 🚫💲 🔚 🔜 🔝 🔄", color.blue);
AddLabel(yes, " ⚠ ✂ 🡇 🡅 🡹 🡻 ★ ☆ ☑ ⬆ ⬇ ⏸ ✅ ↑ ↓ ⇧ ⇩ ✛ ➕ ❌ ❎ ♾ ♡ ♥ ", color.violet) ;
The first label lists the symbols that worked.
The 2nd label is the symbols that didn't. None of the arrows worked :(
a3.png

Thank you @Joshua!
 
Last edited:
Works for me oddly, what method did you use to obtain the characters for the second row? Try to copy and paste your code specifically from your post here, and back into think script. The browser has a way of parsing and rendering out things that shouldn't be there.
 
Last edited:
@Joshua
I do see that you have arrows in your labels. I am jealous! I copied them directly from the Unicode Table: https://unicode-table.com/en/ directly into my AddLabel script, I didn't make any detours into any editors or browsers. Of the 713 arrows, I probably tested at least half of them and couldn't get any of them to work in the AddLabel script.

To troubleshoot, I now tried copying and pasting from a couple different browsers and editors, back into the script and they still don't show :(

Could you post your AddLabel script so I can see if I can get them to load??
To be able to have an arrow instead of writing out rising, trending, falling, etc... would save valuable label and watchlist real estate
 
Last edited:
Try these

▲▼←↑→↓↔↕

Everything I posted was copied and pasted from either the character map program that comes with windows by default, or right from the emoji selector here on this site. The code that you provided also worked fine on my end, so I don't think its a code issue. The characters that don't work for me are already squares in the editor. Are you on Mac possibly?
 
Try these

▲▼←↑→↓↔↕

Everything I posted was copied and pasted from either the character map program that comes with windows by default, or right from the emoji selector here on this site. The code that you provided also worked fine on my end, so I don't think its a code issue. The characters that don't work for me are already squares in the editor. Are you on Mac possibly?
I was not able to get it to work.... Could you share the code that you used ?

/Baba
 
The code is just the add label function, its nothing special. I'm on Windows 10, I also unchecked Use System Font in Setup > Application Settings > Look and Feel, if that matters. I am not really sure why it works for some and not for others.
 
The code is just the add label function, its nothing special. I'm on Windows 10, I also unchecked Use System Font in Setup > Application Settings > Look and Feel, if that matters. I am not really sure why it works for some and not for others.
I am on WIn10 as well and I tried what you suggested but it didnt work.

Thank for taking a look.

/Baba
 
Try these

▲▼←↑→↓↔↕

Everything I posted was copied and pasted from either the character map program that comes with windows by default, or right from the emoji selector here on this site. The code that you provided also worked fine on my end, so I don't think its a code issue. The characters that don't work for me are already squares in the editor. Are you on Mac possibly?

I copied these symbols to use in my script. It works after i save my script. However, after i restart ToS, the symbols are gone and the script is automatically updated to look like below.

Ruby:
input SymbolUp = "?";
input SymbolDown = "?";

I need just these two ▲▼ on my label. Please advise if anything needs to be changed in the system settings.
Thanks!
 
I copied these symbols to use in my script. It works after i save my script. However, after i restart ToS, the symbols are gone and the script is automatically updated to look like below.

Ruby:
input SymbolUp = "?";
input SymbolDown = "?";

I need just these two ▲▼ on my label. Please advise if anything needs to be changed in the system settings.
Thanks!
Regrettably unicodes basically do not work or not for long. For your need, try using the following which are keyboard strokes, slashes, that should last.

Capture.jpg
Ruby:
input SymbolUp = "/\";
input symboldn = "\/";
addlabel(1, symbolup +" "+ symboldn);
 
It seems that the problem is in the basic font used by ThinkorSwim. It is Java-based and the character set of the default font is limited, most likely to something that doesn't have any type of symbols or wingding-type characters. Unless ThinkScript is modified to accept larger character sets, I don't think this will be available. The tone I'm getting from Tech Support at this time is that until they are completely (whatever that means) finished with the Schwab merger and integration, they won't be implementing any feature requests.
 
The thinkscript code is just AddLabel(), the icons are just copied and pasted into that. I wouldn't bother at this point though. I have problems similar to what others have mentioned on my new computer. The emojis become question marks after restarting TOS, and copying/pasting symbols from the windows character map doesn't work anymore at all. On my older laptop, I can do both of those things, and they're permanent. I really wish I knew what the discrepancy is, but I don't. I've tried every possible setting I can think of.
 

Similar threads

Not the exact question you're looking for?

Start a new thread and receive assistance from our community.

87k+ Posts
344 Online
Create Post

Similar threads

Similar threads

The Market Trading Game Changer

Join 2,500+ subscribers inside the useThinkScript VIP Membership Club
  • Exclusive indicators
  • Proven strategies & setups
  • Private Discord community
  • ‘Buy The Dip’ signal alerts
  • Exclusive members-only content
  • Add-ons and resources
  • 1 full year of unlimited support

Frequently Asked Questions

What is useThinkScript?

useThinkScript is the #1 community of stock market investors using indicators and other tools to power their trading strategies. Traders of all skill levels use our forums to learn about scripting and indicators, help each other, and discover new ways to gain an edge in the markets.

How do I get started?

We get it. Our forum can be intimidating, if not overwhelming. With thousands of topics, tens of thousands of posts, our community has created an incredibly deep knowledge base for stock traders. No one can ever exhaust every resource provided on our site.

If you are new, or just looking for guidance, here are some helpful links to get you started.

What are the benefits of VIP Membership?
VIP members get exclusive access to these proven and tested premium indicators: Buy the Dip, Advanced Market Moves 2.0, Take Profit, and Volatility Trading Range. In addition, VIP members get access to over 50 VIP-only custom indicators, add-ons, and strategies, private VIP-only forums, private Discord channel to discuss trades and strategies in real-time, customer support, trade alerts, and much more. Learn all about VIP membership here.
How can I access the premium indicators?
To access the premium indicators, which are plug and play ready, sign up for VIP membership here.
Back
Top